Back to overview
Downtime
Cenedril is not available yet
Nov 15 at 10:38pm CET
Affected services
cenedril.net
Resolved
Nov 20 at 08:00pm CET
cenedril.net is now live.
Affected services
Created
Nov 15 at 10:38pm CET
The Cenedril application has not yet been published to production. Please check back later.
Affected services